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QuickBooks Desktop Error: QBC1039: There was a problem adding the application
QuickBooks Desktop Error: QBC1039: There was a problem adding the application
Updated over a week ago

Issue:

  • Error Code: QBC1039: There was a problem adding the application. Error connecting to QuickBooks. Error message received from QuickBooks was <If the QuickBooks company data file is not open, a call to the ‘BeginSession’ must include the name of the data file>.

Cause:

Cannot Add Application: When first adding the integration application, it requires permission to be given on the QuickBooks company file interface. Adding the application will fail if it cannot detect the correct company file open.

Resolution:

  1. Ensure that the correct company file is open

  2. Select F2 on the QuickBooks interface to check the file path location of the company file

  3. Confirm that it is the same as the company file path listed in Procurify’s integration setting page

  4. Re-add integration application

Additional Information:

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