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QuickBooks Desktop Error: There is an invalid reference to QuickBooks PurchaseOrderLineItem
QuickBooks Desktop Error: There is an invalid reference to QuickBooks PurchaseOrderLineItem
Updated over a week ago

Issue:

  • Error message: There is an invalid reference to QuickBooks PurchaseOrderLineItem [list field name] {AMP}quot; ___[data value]__{AMP}quot; in the Purchase Order line. QuickBooks error message: Invalid argument. The specific record does not exist in the list.

Cause:

Incorrect List Value (Order Item): Integration custom field mappings link Procurify data to QuickBooks field with a drop-down. Data pushed from Procurify must be an exact text match to a value on the QuickBooks list. QuickBooks text match format may be found by exporting a list in .IIF format, rather than displayed format on screen. List examples: Classes, Customers, Job

Resolution:

  1. Locate data in Procurify that is experiencing the error (e.g. custom order request field, department name, etc.)

  2. Correct data value in Procurify to match QuickBooks version (may need to export a list from QuickBooks for format)

  3. Re-run PO integration application

Additional Information:

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