Knowledge Base Home
Contact Us
Sign in
  1. Knowledge Base Home
  2. Product Announcements
  3. Common Questions and Issues for the Customer Experience Team
  1. Common Questions and Issues for the Customer Experience Team
  • April 19, 2023 16:01
  • Updated

I can't find the password reset email in my inbox

Issue:

  • My password reset email didn't go to my inbox
  • I can't find the password reset option in my email
  • Where is my password reset 

 

Cause:

1) The email address does not have Procurify's IP Whitelisted as a sender

2) The email went to the spam or junk folder

3) Spelling mistake in the email address on the domain 

 

Resolution:

  1. Your IT team will need to whitelist Procurify's IP as a safe sender
  2. Check your spam or junk folder, you may have to add the email address notifications@mailer.procurify.com to your safe sender's list within your email settings.
  3. Contact your superuser to check that the spelling of the email address on the domain matches the one you use.

 

Additional Information:

  • If multiple users are not receiving emails from Procurify, reach out to your IT team to ensure Procurify is whitelisted for all users
Was this article helpful?
0 out of 0 found this helpful
Return to top