QuickBooks Desktop Error: String too long
Updated over a week ago

Issue:

  • Receiving an error message: String too long

Cause:

Each field in QuickBooks has a character limit for data input. Procurify fields may have a higher character limit than matching QuickBooks fields. When the larger Procurify data tries to push over to QuickBooks, an error message will occur if data exceed the character limit.

Resolution:

  1. Locate data in Procurify that is experiencing the error

  2. Review QuickBooks character limit guide to understand how many characters over QuickBooks limit

  3. Correct data value in Procurify by shortening the data being exported

  4. Re-run PO integration application

If you cannot edit Procurify data:

  • Archive PO from ‘Exportable’ queue in Procurify

  • Manually create PO in QuickBooks and shorten the text for the affected field

Additional Information:

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