Issue:
Receiving error message: Invalid argument. The specified record does not exist in the list.
Cause:
Integration custom field mappings link Procurify data to QuickBooks field with a drop-down. Data pushed from Procurify must be an exact text match to a value on the QuickBooks list. QuickBooks text match format may be found through exporting a list in IIF format, rather than displayed format on the screen. List examples: Classes, Customers, Job
Resolution:
Locate data in Procurify that is experiencing the error (eg. order request custom field, department name, etc). The error log should specify what's is experiencing the error.
Correct data value in Procurify to match QuickBooks version (may need to export the list from QuickBooks for format)
Re-run PO integration application
Additional Information:
To find the error message that you are looking for in the quickest way possible, press on Ctrl+F on Windows and Command + F on Mac