Knowledge Base Home
Contact Us
Sign in
  1. Knowledge Base Home
  2. Product Announcements
  3. Common Questions and Issues for the Customer Experience Team
  1. Common Questions and Issues for the Customer Experience Team
  • December 22, 2022 21:36
  • Updated

"Procurify, we have a problem...": Log-in error message

Issue:

  • Receiving an error message when attempting to log into Procurify 

mceclip0.png

Cause:

The login page was accessed using an outdated web URL. 

 

Resolution:

  1. Access the Procurify Login page: https://www.procurify.com/login 
  2. Type in the name of your company's domain 
  3. Select Go To My Log In 
  4. Login into Procurify by entering your email and password or by selecting Log in with Google

 

Additional Information:

  • N/A 
Was this article helpful?
0 out of 0 found this helpful
Return to top