All Collections
Accounting Integrations
QuickBooks Online & Desktop
QuickBooks Desktop
QuickBooks Desktop Error: Error Connecting to QuickBooks
QuickBooks Desktop Error: Error Connecting to QuickBooks
Updated over a week ago

Issue:

  • Error connecting to QuickBooks. Error message received from QuickBooks was <A QuickBooks company data file is already open and is different from the one requested or there are multiple company files open

Cause:

Multiple Company File: Integration applications require only one company file to be open while integration is running. If there is a different company file open, or a company files open in the background processes of the desktop, an error will occur.

Resolution:

  1. Check if the opened company file is the correct company file linked to Procurify integration

  2. Current company file: select F2 to open the company file information page to see the Location file path

  3. Procurify: open Settings β†’ Integrations β†’ QuickBooks to see the company file path specified on the integration setting page

  4. Check if multiple QuickBooks instances open

  5. Close the company file that does not match the one specified within Procurify

  6. Check if there are any QuickBooks instances open in the background processes

  7. Open task manager and scroll to the background processes

  8. Close any QuickBooks instances found in the background processes

  9. Re-run integration application

Additional Information:

Did this answer your question?