Issue:
- Error connecting to QuickBooks. Error message received from QuickBooks was <A QuickBooks company data file is already open and is different from the one requested or there are multiple company files open
Cause:
Multiple Company File: Integration applications require only one company file to be open while integration is running. If there is a different company file open, or a company files open in the background processes of the desktop, an error will occur.
Resolution:
- Check if the opened company file is the correct company file linked to Procurify integration
- Current company file: select F2 to open the company file information page to see the Location file path
- Procurify: open Settings → Integrations → QuickBooks to see the company file path specified on the integration setting page
- Check if multiple QuickBooks instances open
- Close the company file that does not match the one specified within Procurify
- Check if there are any QuickBooks instances open in the background processes
- Open task manager and scroll to the background processes
- Close any QuickBooks instances found in the background processes
- Re-run integration application
Additional Information:
- To find the error message that you are looking for in the quickest way possible, press Ctrl+F on Windows and Command+F on Mac
- QuickBooks Desktop Troubleshooting Guide