Issue:
Error: Account code doesn't exist in QuickBooks Desktop
Cause:
There are Account Codes from Procurify that you used to create the request and it does not exist in QuickBooks.
Resolution:
First, create the new Account Code you want to sync in QuickBooks. Open the QuickBooks software, and hover over List โ Chart of Accounts โ then New. Make sure to fill in the number section of the Account Code located at the top right-hand side of the window.
Once the Account Code is created, run the webconnector again this time for Chart of Accounts.
Once the sync is completed, go back to the Integration page and go under Accounts. You will see a Chart of Accounts that were created in QuickBooks that are ready to be mapped over to Procurify.
Now, because the Account Code already exists in Procurify, what you can do is to select the check box for Account Code in a question and then IMPORT.
It will prompt you that the Account Code exists. Click the checkbox on the Account Code again, and map them. This will allow the sync to map the same Account Code that you just created in QuickBooks.
Run the Purchase order sync again, and it should sync with the newly mapped Account Code.