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I can't find the password reset email in my inbox
I can't find the password reset email in my inbox
Updated over 10 months ago

Issue:

  • My password reset email didn't go to my inbox

  • I can't find the password reset option in my email

  • Where is my password reset

Possible Causes:

  • The email address does not have Procurify's IP Allowlist as a sender

  • The email went to the spam or junk folder

  • The email address was entered incorrectly on the domain

Resolution:

  • Your IT team will need to allowlist Procurify's IP as a safe sender

  • Check your spam or junk folder, you may have to add the email address [email protected] to your safe sender's list within your email settings.

  • Contact your superuser to check that the spelling of the email address on the domain matches the one you use.

Additional Information:

  • If multiple users are not receiving emails from Procurify, reach out to your IT team to ensure Procurify is allowlisted for all users

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