Issue:
Approval Delegation is turned on, but some orders are not being delegated.
Orders not delegating
Why doesn't delegation work?
Cause:
When you set up Approval Delegation, there is an option to move all existing Pending Approvals to the assignee. If this is not checked, previously submitted orders will not be delegated.
Resolution:
Turn off and reactivate the delegation ensuring to check the box for Move Pending Approvals
Select Settings > Manage Users
Find and select the Approver.
Select the Approver Settings tab
Select Cancel Delegation
Select Continue
Select the Delegate button.
Check the box for Move Pending Approvals
Select the user you wish to Delegate to from the Assign To drop-down menu
Select Submit
Additional Information:
For more information on Approval Routing, review Approval Routing Overview