Issue:
- Receiving an error message: String too long
Cause:
Each field in QuickBooks has a character limit for data input. Procurify fields may have a higher character limit than matching QuickBooks fields. When the larger Procurify data tries to push over to QuickBooks, an error message will occur if data exceed the character limit.
Resolution:
- Locate data in Procurify that is experiencing the error
- Review QuickBooks character limit guide to understand how many characters over QuickBooks limit
- Correct data value in Procurify by shortening the data being exported
- Re-run PO integration application
If you cannot edit Procurify data:
- Archive PO from ‘Exportable’ queue in Procurify
- Manually create PO in QuickBooks and shorten the text for the affected field
Additional Information:
- To find the error message that you are looking for in the quickest way possible, press Ctrl+F on Windows and Command + F on Mac
- QuickBooks Desktop Troubleshooting Guide