Issue:
- Receiving error when trying to setup Amazon PunchOut
- Issue happening in the setup process in Settings
Cause:
The information inputted in PunchOut Settings are likely incorrect. The fields include:
- PunchOut Domain: The domain must match the same domain used when setting up the Amazon Business Account.
- Purchase Order Request URL: The URL must match the URL found in your Amazon Business Account. Important: Do not use the cXML PunchOut URL in the Purchase Order Request URL field.
- FROM Identity: The field must match the identity found in your Amazon Business Account.
- Shared Secret: The field must match the shared secret found in your Amazon Business Account.
Resolution:
Ensure that you are following the instructions, and pulling the data points directly from your Amazon Business account, or else the error will occur. The instructions are as follows:
In a separate webpage (open a new tab), open and log into your Amazon Business Account. Hover your mouse over your name and organization name available in the top right of your screen. Select Business Settings. Scroll to the bottom of the System Integrations section and select Purchasing System.
- Open Procurify Settings
- Click PunchOut Suppliers
- Select the PunchOut experiencing issues by clicking View
- Beside the PunchOut group click ". . . " to edit
- Select Edit Group
- Copy the Purchase Order Request URL and paste it into the Procurify. Important: Do not use the cXML PunchOut URL in the Purchase Order Request URL field.
- Copy the "From Identity" in cXML and paste it into the Form Identify field in Procurify.
- Copy the "Shared Secret" in cXML and paste it into the