Issue:
- Receiving error when trying to setup Amazon PunchOut
- Issue happening in the setup process in Settings
Cause:
The information inputted in PunchOut Settings are likely incorrect. The fields include:
- PunchOut Domain: The domain must match the same domain used when setting up the Amazon Business Account.
- Purchase Order Request URL: The URL must match the URL found in your Amazon Business Account.
- Important: Do not use the cXML PunchOut URL in the Purchase Order Request URL field.
- FROM Identity: The field must match the identity found in your Amazon Business Account.
- Shared Secret: The field must match the shared secret found in your Amazon Business Account.
Resolution:
In Amazon
To retrieve PunchOut credentials for your Amazon Business account:
- Open and log into your Amazon Business Account.
- Hover over your name in the top right and select Business Settings.
- Scroll to the bottom of the System Integrations section and select Purchasing System.
In Procurify
- Navigate to Settings → PunchOut Suppliers
- Click View beneath the applicable PunchOut
- Click the 3-dot options button to edit the Punchout and select Edit Group
- Copy the Purchase Order Request URL and paste it into the Procurify. Important: Do not use the cXML PunchOut URL in the Purchase Order Request URL field.
- Copy the "From Identity" in cXML and paste it into the Form Identify field in Procurify.
- Copy the "Shared Secret" in cXML and paste it into the